репликация и как сделать резервный контролер домена

Ответить
 • Просмотры: 2
Аватара пользователя
skull

Re: репликация и как сделать резервный контролер домена

Сообщение skull »

Вообщем так:



Стоит у меня основной КД на Windows 2003 Server

имя домена ntv.local

имя сервера alkasar

IP: 192.168.1.10, статический естественно

в настройках TCP/IP DNS сервером стоит IP этого же интерфейса

в самом DNS сервере поставлена пересылка неизвестных запросов на DNS'ы провайдера



Все работало без проблем, пока не начал настраивать второй КД.



Что делал:

поставил Windows Server 2003 R2, включил сервак в домен.

имя сервера: server

IP: 192.168.1.2, статический

Установил DNS сервер, скопировал зону с основного КД, настроил пересылку запросов на DNS провайдера.

Далее, в настройках TCP/IP в качестве первого DNS указал IP основного КД, в качестве альтернативного указал IP этого же интерфейса.

далее установил роль дополнительного контроллера домена.

потом установил глобальный каталог на дополнительном КД.

Перезагрузился.



Собственно на дополнительном КД в оснастке "Active Directory: пользователи и компьютеры" появились юзвери, группы и т.д. с основного КД.

И я было уже обрадовался и полез смотреть в журналы как все прошло и обнаружил следующие предупреждения:



на основном КД:



в журнале службы каталогов:





Код:

Код: Выделить всё

Event Type:	Warning
Event Source:	NTDS Replication
Event Category:	Replication 
Event ID:	2092
Date:		29.05.2009
Time:		19:50:52
User:		NT AUTHORITY\ANONYMOUS LOGON
Computer:	ALKASAR
Description:
This server is the owner of the following FSMO role, but does not consider it valid. For the partition which contains the FSMO, this server has not replicated successfully with any of its partners since this server has been restarted. Replication errors are preventing validation of this role. 
Operations which require contacting a FSMO operation master will fail until this condition is corrected. 
FSMO Role: CN=Schema,CN=Configuration,DC=ntv,DC=local 
Event Type:	Warning
Event Source:	NTDS Replication
Event Category:	DS RPC Client 
Event ID:	2088
Date:		29.05.2009
Time:		18:51:27
User:		NT AUTHORITY\ANONYMOUS LOGON
Computer:	ALKASAR
Description:
Active Directory could not use DNS to resolve the IP address of the source domain controller listed below. To maintain the consistency of Security groups, group policy, users and computers and their passwords, Active Directory successfully replicated using the NetBIOS or fully qualified computer name of the source domain controller. 
Invalid DNS configuration may be affecting other essential operations on member computers, domain controllers or application servers in this Active Directory forest, including logon authentication or access to network resources. 
You should immediately resolve this DNS configuration error so that this domain controller can resolve the IP address of the source domain controller using DNS. 
Alternate server name: 
 server 
Failing DNS host name: 
 3bc660c2-37fd-42c4-90c6-440577401455._msdcs.ntv.local 
Event Type:	Warning
Event Source:	NTDS KCC
Event Category:	Knowledge Consistency Checker 
Event ID:	1925
Date:		28.05.2009
Time:		23:08:27
User:		NT AUTHORITY\ANONYMOUS LOGON
Computer:	ALKASAR
Description:
The attempt to establish a replication link for the following writable directory partition failed. 
Directory partition: 
CN=Configuration,DC=ntv,DC=local 
Source domain controller: 
CN=NTDS Settings,CN=SERVER,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=ntv,DC=local 
Source domain controller address: 
3bc660c2-37fd-42c4-90c6-440577401455._msdcs.ntv.local 
Intersite transport (if any): 
This domain controller will be unable to replicate with the source domain controller until this problem is corrected.

в журнале службы репликации фалов:





Код:

Код: Выделить всё

Event Type:	Error
Event Source:	NtFrs
Event Category:	None
Event ID:	13568
Date:		29.05.2009
Time:		18:51:50
User:		N/A
Computer:	ALKASAR
Description:
The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR. 
 Replica set name is    : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" 
 Replica root path is   : "c:\windows\sysvol\domain" 
 Replica root volume is : "\\.\C:" 
 A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found.  This can occur because of one of the following reasons. 
 [1] Volume "\\.\C:" has been formatted. 
 [2] The NTFS USN journal on volume "\\.\C:" has been deleted. 
 [3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal. 
 [4] File Replication Service was not running on this computer for a long time. 
 [5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\C:". 
 Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state. 
 [1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service. 
 [2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set. 
WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again. 
To change this registry parameter, run regedit. 
Click on Start, Run and type regedit. 
Expand HKEY_LOCAL_MACHINE. 
Click down the key path: 
   "System\CurrentControlSet\Services\NtFrs\Parameters" 
Double click on the value name 
   "Enable Journal Wrap Automatic Restore" 
and update the value. 
If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

на дополнительном КД:



в журнале службы каталогов:





Код:

Код: Выделить всё

Тип события:	Предупреждение
Источник события:	NTDS Replication
Категория события:	DS RPC-клиент 
Код события:	2088
Дата:		29.05.2009
Время:		18:58:20
Пользователь:		NT AUTHORITY\АНОНИМНЫЙ ВХОД
Компьютер:	SERVER
Описание:
Active Directory не может использовать DNS для разрешения указанного ниже IP—адреса исходного контроллера домена. Чтобы сохранить согласованность групп безопасности, групповой политики, пользователей и компьютеров и их паролей, Active Directory была успешно реплицирована с помощью NetBIOS или полное доменное имя исходного контроллера домена. 
 Неправильная настройка DNS может влиять на другие важные операции на рядовых компьютерах, контроллерах домена или серверах приложений в лесе этой службы каталогов Active Directory, включая проверку подлинности при входе или доступ к сетевым ресурсам. 
 Следует как можно скорее исправить ошибку настройки DNS, чтобы этот контроллер домена мог выполнять разрешение IP—адреса исходного контроллера домена с помощью DNS. 
 Имя альтернативного сервера: 
 alkasar.ntv.local 
 Ошибочное имя узла DNS: 
 aa7915e8-053a-4416-9df0-8fb888ab8956._msdcs.ntv.local



Код:

Код: Выделить всё

Тип события:	Предупреждение
Источник события:	NtFrs
Категория события:	Отсутствует
Код события:	13508
Дата:		31.05.2009
Время:		21:13:01
Пользователь:		Н/Д
Компьютер:	SERVER
Описание:
Служба репликации файлов столкнулась с проблемами при включении репликации с "\\alkasar.ntv.local" на "SERVER" для "c:\windows\sysvol\domain", использующего DNS-имя "\\alkasar.ntv.local". Служба репликации файлов (FRS) продолжит повторные попытки. 
 Ниже указаны причины, по которым может выдаваться это предупреждение. 
 [1] FRS не может разрешить DNS-имя "\\alkasar.ntv.local" с этого компьютера. 
 [2] FRS не запущена на "\\alkasar.ntv.local". 
 [3] Сведения в Active Directory о топологии для этой реплики реплицированы еще не на все контроллеры домена.

Папочка sysvol так и не появилась на втором сервере. Службы DFS и репликации включены и работают на обоих КД.



Когда набираю \\ntv.local на основном КД, то попадаю на дополнительный, но не могу зайти ни в одну расшаренную папку.

Когда набираю \\ntv.local на дополнительном КД, то попадаю на основной, могу зайти в папочки sysvol и netlogon, а в остальные расшаренные папки не могу попасть.



Подскажите в чем дело, плиз. Почему то кажется, что в DNS. Какие данные необходимо еще привести?
Аватара пользователя
hnsk

Re: репликация и как сделать резервный контролер домена

Сообщение hnsk »

доброго времени суток!



win2k3 st.ed.

состояние:

dc - 10.3 ad + dns

sdc - 10.4 dns



настроки днс на серверах

dc

dns: 10.3



sdc

dns: 10.3

10.4





в логах ошибок нету

dcdiag и netdiag проходят нормально на обоих серверах

dns прекрасно реплецируется





пробую повысить sdc до DC



1dcpromo /adv

2дополнительный контроллер домена в этом домене

3по сети с контроллера домен

4user

pass

domianname



5 обзор - domianame

6 папка располежения БД

папка расположения журнала

оставляю по умолчанию

7 размещение папки sysvol - по умолчанию





идет процесс повышения роли

ребут



dc - netdiag, dcdiag - ok



sdc- netdiag, dcdiag - ok





далее создаю учетку проверяю появится ли она на дополнительном dc





учетка создалась!



теперь иммитирую выход их строя dc





перезагружаю sdc



очень долго ждет "настройка сетевых подключений"







вопрос если же они независимые, а только копируются друг с друга, то в чем собственно проблема?!)



на sdc

источник ntds replication

кактегория ds rpc-клиент

код 2087

вопрос это нормальное поведение серверов в такой ситуации?





после ребута обоих серверов dcdiag'и ругаются на репликацию

sdc



ntds perlication

репликация

1586



ntds kcc

проверка согласований знаний

1308



ntds replication

ds rpc-клиент

2088



dc

ntds replication

ds rpc-клиент

2088



ntds kcc

проверка согласований знаний

1308





вопрос как проходит репликация?

есть ли еще какие-нибудь методы проверки правильности работы серверов кроме dcdiag и netdiag?

имеет ли смысл делать дополнительный КД владельцем ГК?



как сделать принудительную синхронизацию серверов?

и вообще какое нормально повоеденеи КД при неисправности другого? репликация синхронизация времени это понятно, а что еще?!

на сайте микрософта ответ на свой вопросы я не нашел :-(
Аватара пользователя
hnsk

Re: репликация и как сделать резервный контролер домена

Сообщение hnsk »

hnsk, само собой, что у вас не будет авторизации при отключении первого контроллера. Для того, чтобы второй сервер смог обслуживать вход в систему, необходимо на этом сервере установить галку "Глобальный каталог" в оснастке "Сайты и службы" - ntds settings. Только после этого второй контроллер будет обслуживать клиентов.
Аватара пользователя
hnsk

Re: репликация и как сделать резервный контролер домена

Сообщение hnsk »

Delirium,

спасибо!

а в остальном, что еще необходимо сделать?
Аватара пользователя
hnsk

Re: репликация и как сделать резервный контролер домена

Сообщение hnsk »

hnsk, да в принципе ничего Изображение если DNS работает корректно, AD работает, то в принципе можно ничего и не трогать.
Аватара пользователя
Delirium

Re: репликация и как сделать резервный контролер домена

Сообщение Delirium »

Delirium, dcdiag и netdiag ругаются только когда один из серверов отключен
Аватара пользователя
Delirium

Re: репликация и как сделать резервный контролер домена

Сообщение Delirium »

foxbat, галка Глобального каталога может стоять хоть на всех контроллерах, не обязательно на одном. Просто без этой галки все контроллеры - не более чем реплика AD, услуг по авторизации пользователей они не проводят. В вашем случае порядок примерно такой:

1. Передача ролей на новый сервер (или на несколько других, как угодно).

2. Выставление галки "глобального каталога" на новом контроллере. Дожидаемся окончания репликаций и операции.

3. Понижаем старый контроллер до уровня рядового сервера(без AD). Все, старый сервер можно тушить.
Аватара пользователя
jabob

Re: репликация и как сделать резервный контролер домена

Сообщение jabob »

помогите советом - запутался!



два сервака - новый new и старый old? нужно старый перенести на новый, делаю:

на new ставлю ОС, ввожу в домен, а дальше уже проблемы и путаница у меня(. запутался до того, что не понимаю, где присваивать и кому роли...



разъясните подробно, пожалуйста как делать... на new установить роль AD? или на old установить роль для new?

проблемы, которые возникали в обоих случаях: 1 - не получается создать дочерний Контроллер Домена (ошибка DNS имени), 2 - еще одну AD нельзя создать, только удалить...

old сервер - win2k3 sp2.

ps - цель - перенести все настройки и данные так, чтобы пользователи этого и не заметили) и старый сервак списать в утиль.
Ответить

Вернуться в «Microsoft Windows NT/2000/2003»