2008 R2 - Ошибка печати на терминальном сервере

Ответить
 • Просмотры: 5
Аватара пользователя
kolesik_24

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение kolesik_24 »

Цитата ruslan...:



vsokol,

Просмотрите в Диспетчере задач, один ли процесс spoolsv.exe на момент создания дампа.

Попробуйте следующее:

Цитата Petya V4sechkin:

При запуске ProcDump для создания дампа вместо имени процесса (spoolsv.exe) укажите его PID (посмотрите "ИД процесса" в "Диспетчере задач"). »
2008 R2 - Ошибка печати на терминальном сервере




у меня служба называется spooler а pid 5640,при попытке запуска выдает ошибку что неправильно



пробовал C:\ProcDump\procdump.exe -accepteula -e -w pid5640 C:\ProcDump

выдает



Скрытый текст

[spoiler]ProcDump v7.1 - Writes process dump files

Copyright (C) 2009-2014 Mark Russinovich

Sysinternals -
www.sysinternals.com


With contributions from Andrew Richards



Monitors a process and writes a dump file when the process exceeds the

specified criteria or has an exception.



usage: procdump [-a] [[-c|-cl CPU usage] [-u] [-s seconds]] [-n exceeds] [-e [1]

[-b]] [-f ] [-g] [-h] [-l] [-m|-ml commit usage] [-ma | -mp] [-o] [

-p|-pl counter threshold] [-r [1..5]] [-t] [-d ] [-64]



-a Avoid outage. Requires -r. If the trigger will cause the target

to suspend for a prolonged time due to an exceeded concurrent

dump limit, the trigger will be skipped.

-b Treat debug breakpoints as exceptions (otherwise ignore them).

-c CPU threshold above which to create a dump of the process.

-cl CPU threshold below which to create a dump of the process.

-d Invoke the minidump callback routine named MiniDumpCallbackRoutine

of the specified DLL.

-e Write a dump when the process encounters an unhandled exception.

Include the 1 to create dump on first chance exceptions.

-f Filter on the content of exceptions and debug logging.

Wildcards (*) are supported.

-g Run as a native debugger in a managed process (no interop).

-h Write dump if process has a hung window (does not respond to

window messages for at least 5 seconds).

-i Install ProcDump as the AeDebug postmortem debugger.

Only -ma, -mp, -d and -r are supported as additional options.

Uninstall (-u only) restores the previous configuration.

-l Display the debug logging of the process.

-m Memory commit threshold in MB at which to create a dump.

-ml Trigger when memory commit drops below specified MB value.

-ma Write a dump file with all process memory. The default

dump format only includes thread and handle information.

-mp Write a dump file with thread and handle information, and all

read/write process memory. To minimize dump size, memory areas

larger than 512MB are searched for, and if found, the largest

area is excluded. A memory area is the collection of same

sized memory allocation areas. The removal of this (cache)

memory reduces Exchange and SQL Server dumps by over 90%.

-n Number of dumps to write before exiting.

-o Overwrite an existing dump file.

-p Trigger on the specified performance counter when the threshold

is exceeded. Note: to specify a process counter when there are

multiple instances of the process running, use the process ID

with the following syntax: "\Process(_)\counter"

-pl Trigger when performance counter falls below the specified value.

-r Dump using a clone. Concurrent limit is optional (default 1, max 5).

CAUTION: a high concurrency value may impact system performance.

- Windows 7 : Uses Reflection. OS doesn't support -e.

- Windows 8.0 : Uses Reflection. OS doesn't support -e.

- Windows 8.1+: Uses PSS. All trigger types are supported.

-s Consecutive seconds before dump is written (default is 10).

-t Write a dump when the process terminates.

-u Treat CPU usage relative to a single core (used with -c).

As the only option, Uninstalls ProcDump as the postmortem debugger.

-w Wait for the specified process to launch if it's not running.

-x Launch the specified image with optional arguments.

If it is a Store Application or Package, ProcDump will start

on the next activation (only).

-64 By default ProcDump will capture a 32-bit dump of a 32-bit process

when running on 64-bit Windows. This option overrides to create a

64-bit dump. Only use for WOW64 subsystem debugging.



Use the -accepteula command line option to automatically accept the

Sysinternals license agreement.



Use -? -e to see example command lines.



If you omit the dump file name, it defaults to _.dmp.[/spoiler]






какую команду нужно вводить ?
Аватара пользователя
kolesik_24

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение kolesik_24 »

Цитата vsokol:



у меня служба называется spooler
2008 R2 - Ошибка печати на терминальном сервере




Смотреть нужно не на вкладке Службы, а на вкладке Процессы, процесс spoolsv.exe. Его ID.


Цитата vsokol:



какую команду нужно вводить ?
2008 R2 - Ошибка печати на терминальном сервере




К примеру команду нужно вводить так



Код:

Код: Выделить всё

C:\ProcDump\procdump.exe -accepteula -e 5640 C:\ProcDump\

Если с ID, то без параметра -w
Аватара пользователя
kolesik_24

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение kolesik_24 »

параметр C:\ProcDump\procdump.exe -accepteula -e 5640 C:\ProcDump\ не помогает,ошибка печати выходит но дамп не сохраняется

что еще можно сделать?
Аватара пользователя
User001

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение User001 »

Цитата vsokol:



параметр C:\ProcDump\procdump.exe -accepteula -e 5640 C:\ProcDump\ не помогает
2008 R2 - Ошибка печати на терминальном сервере




Я этот параметр написал к примеру.

Посмотрите на вкладке Процессы, процесс spoolsv.exe какой имеет ID ?

Сделайте скриншот этого процесса.
Аватара пользователя
kolesik_24

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение kolesik_24 »

во вкладке процессы ид посмотреть нельзя,только службы

вот скрины

http://forum.oszone.net/attachment.p...1&d=1427188169


http://forum.oszone.net/attachment.p...1&d=1427188635


что то мне подсказывает что нужно добавить какую то команду что бы программа создала дамп

смотрю на сайте
технет
описание команд программы

примеры

-e Написать дамп, когда процесс обнаруживает необработанное исключение. Включить 1 для создания дампа на первой же возможности исключений.

непонятно что обозначает включить 1?
Аватара пользователя
vsokol

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение vsokol »

Цитата vsokol:



во вкладке процессы ид посмотреть нельзя
2008 R2 - Ошибка печати на терминальном сервере




Вид > Выбрать столбцы.


Цитата vsokol:



вот скрины
2008 R2 - Ошибка печати на терминальном сервере




Нет скринов по ссылкам.
Аватара пользователя
vsokol

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение vsokol »

Скрытый текст

[spoiler]Изображение

Изображение[/spoiler]




что только не пробовал,будет ли нормальный дамп если сделать так:

C:\ProcDump\procdump.exe -accepteula -e 1 -t spoolsv.exe C:\ProcDump\

т.е. после возникновения ошибки я вручную перезапускаю диспетчер печати и создается дамп,или таким методом дамп будет некоректный?
Аватара пользователя
ruslan...

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение ruslan... »

На вкладке процессы

Вид > Выбрать столбцы - поставьте галку на ИД процесса (PID)
Аватара пользователя
vsokol

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение vsokol »

Цитата ruslan...:



На вкладке процессы

Вид > Выбрать столбцы - поставьте галку на ИД процесса (PID)
2008 R2 - Ошибка печати на терминальном сервере




вот



Скрытый текст

[spoiler]Изображение[/spoiler]
Аватара пользователя
vsokol

Re: 2008 R2 - Ошибка печати на терминальном сервере

Сообщение vsokol »

vsokol,



Вы проследите, когда падает Диспетчер печати, процесс spoolsv.exe завершает работу ? Можете попробовать завершить вручную процесс и проверить, создастся ли дамп.


Цитата vsokol:



т.е. после возникновения ошибки я вручную перезапускаю диспетчер печати и создается дамп,или таким методом дамп будет некоректный?
2008 R2 - Ошибка печати на терминальном сервере




Давайте уж какой-нибудь. Без дампа сказать ничего не возможно.
Ответить

Вернуться в «Windows Server 2008/2008 R2»